scroll container not working

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

scroll container not working

Skar-3
Hi,

I upgraded to latest trunk 20269 and my started giving me error about scroll like below:

qx.ui.core.scroll is undefined
However, my app works with a 2 week old version of trunk perfectly fine. Any ideas?

cheers,
skar.

------------------------------------------------------------------------------
Come build with us! The BlackBerry® Developer Conference in SF, CA
is the only developer event you need to attend this year. Jumpstart your
developing skills, take BlackBerry mobile applications to market and stay
ahead of the curve. Join us from November 9-12, 2009. Register now!
http://p.sf.net/sfu/devconf
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
Reply | Threaded
Open this post in threaded view
|

Re: scroll container not working

Fabian Jakobs
Administrator
Hi skar,
> I upgraded to latest trunk 20269 and my started giving me error about
> scroll like below:
>
>> qx.ui.core.scroll is undefined
>> Scroll.js()Scroll.js (line 61)
>>  extend : qx.ui.core.scroll.AbstractScrollArea,\nScroll.js (line 61)
> However, my app works with a 2 week old version of trunk perfectly
> fine. Any ideas?
To add the option for native scroll bars I've moved a few files around.
After a rebuild your application should work just fine.

Best Fabian

--
Fabian Jakobs
JavaScript Framework Developer

1&1 Internet AG - Web Technologies
Ernst-Frey-Straße 9 · DE-76135 Karlsruhe
Telefon: +49 721 91374-6784
[hidden email]

Amtsgericht Montabaur / HRB 6484
Vorstände: Henning Ahlert, Ralph Dommermuth, Matthias Ehrlich, Thomas Gottschlich, Robert Hoffmann, Markus Huhn, Hans-Henning Kettler, Dr. Oliver Mauss, Jan Oetjen
Aufsichtsratsvorsitzender: Michael Scheeren


------------------------------------------------------------------------------
Come build with us! The BlackBerry® Developer Conference in SF, CA
is the only developer event you need to attend this year. Jumpstart your
developing skills, take BlackBerry mobile applications to market and stay
ahead of the curve. Join us from November 9-12, 2009. Register now!
http://p.sf.net/sfu/devconf
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
Reply | Threaded
Open this post in threaded view
|

Re: scroll container not working

Skar-3
Fabian Jakobs wrote:
Hi skar,
  
I upgraded to latest trunk 20269 and my started giving me error about 
scroll like below:

    
qx.ui.core.scroll is undefined
Scroll.js()Scroll.js (line 61)
 extend : qx.ui.core.scroll.AbstractScrollArea,\nScroll.js (line 61)
      
However, my app works with a 2 week old version of trunk perfectly 
fine. Any ideas?
    
To add the option for native scroll bars I've moved a few files around. 
After a rebuild your application should work just fine.
  
I deleted the cache and rebuilt the app and now I get the error:

>>> Resolving dependencies...
!!! Expected token/COMMA but found token/RP: ')'. file:qx.ui.core.scroll.NativeScrollBar, line:323, column:2
Do I need to clear the cache when building using a new trunk version?

cheers,
skar.
-- 
--
The life so short, the craft so long to learn. 

------------------------------------------------------------------------------
Come build with us! The BlackBerry® Developer Conference in SF, CA
is the only developer event you need to attend this year. Jumpstart your
developing skills, take BlackBerry mobile applications to market and stay
ahead of the curve. Join us from November 9-12, 2009. Register now!
http://p.sf.net/sfu/devconf
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
Reply | Threaded
Open this post in threaded view
|

Re: scroll container not working

Daniel Hirtzbruch

Hello Skar,

theres an JS error in trunk, removing lines 317/318 in File
/qx/ui/core/scroll/NativeScrollBar.js works just fine. Code:

    /**
     * Stops propagation on the given even
     *
     * @param e {qx.event.type.Event} the event
     */
    _onScroll : function(e)
    {
    _stopPropagation : function(e) {
      e.stopPropagation();
    }
  }

The code
    _onScroll : function(e)
    {
has to be removed.

Regards,
Daniel


skar karthikeyan wrote:
>
> I deleted the cache and rebuilt the app and now I get the error:
>
>> >>> Resolving dependencies...
>> !!! Expected token/COMMA but found token/RP: ')'.
>> file:qx.ui.core.scroll.NativeScrollBar, line:323, column:2
>

--
View this message in context: http://www.nabble.com/scroll-container-not-working-tp25746566p25748546.html
Sent from the qooxdoo-devel mailing list archive at Nabble.com.


------------------------------------------------------------------------------
Come build with us! The BlackBerry® Developer Conference in SF, CA
is the only developer event you need to attend this year. Jumpstart your
developing skills, take BlackBerry mobile applications to market and stay
ahead of the curve. Join us from November 9-12, 2009. Register now!
http://p.sf.net/sfu/devconf
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
Reply | Threaded
Open this post in threaded view
|

Re: scroll container not working

Fabian Jakobs
Administrator
In reply to this post by Skar-3
skar schrieb:

> Fabian Jakobs wrote:
>> Hi skar,
>>  
>>> I upgraded to latest trunk 20269 and my started giving me error about
>>> scroll like below:
>>>
>>>    
>>>> qx.ui.core.scroll is undefined
>>>> Scroll.js()Scroll.js (line 61)
>>>>  extend : qx.ui.core.scroll.AbstractScrollArea,\nScroll.js (line 61)
>>>>      
>>> However, my app works with a 2 week old version of trunk perfectly
>>> fine. Any ideas?
>>>    
>> To add the option for native scroll bars I've moved a few files around.
>> After a rebuild your application should work just fine.
>>  
> I deleted the cache and rebuilt the app and now I get the error:
>
>> >>> Resolving dependencies...
>> !!! Expected token/COMMA but found token/RP: ')'.
>> file:qx.ui.core.scroll.NativeScrollBar, line:323, column:2
You don't have to clean the cache. Just rebuilding will do it. The error
you get is caused by a bad commit of mine. Please update to r20275.

Sorry about that.

Best Fabian

--
Fabian Jakobs
JavaScript Framework Developer

1&1 Internet AG - Web Technologies
Ernst-Frey-Straße 9 · DE-76135 Karlsruhe
Telefon: +49 721 91374-6784
[hidden email]

Amtsgericht Montabaur / HRB 6484
Vorstände: Henning Ahlert, Ralph Dommermuth, Matthias Ehrlich, Thomas Gottschlich, Robert Hoffmann, Markus Huhn, Hans-Henning Kettler, Dr. Oliver Mauss, Jan Oetjen
Aufsichtsratsvorsitzender: Michael Scheeren


------------------------------------------------------------------------------
Come build with us! The BlackBerry® Developer Conference in SF, CA
is the only developer event you need to attend this year. Jumpstart your
developing skills, take BlackBerry mobile applications to market and stay
ahead of the curve. Join us from November 9-12, 2009. Register now!
http://p.sf.net/sfu/devconf
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel