Moving from v0.8 SDK to v0.8.1 SDK - error in generate.py

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Moving from v0.8 SDK to v0.8.1 SDK - error in generate.py

Amit Rana
Hi,

I am able to run my application successfully using v0.8 SDK. Now, I wanted to test it using v0.8.1 and am some facing problems. I went through the online help and have some queries.

1.       1. I wanted to highlight one thing mentioned at : http://qooxdoo.org/documentation/0.8/setting_a_different_application_root. It says
      "QOOXDOO_PATH" : "PATH_TO_FRAMEWORK_FOLDER",

    I think this was true in v0.8. But in v0.8.1, it should just point to the SDK folder (containing the framework folder), else it gives an error.

 2. When I call generate.py source, I get an error stating :

      File "...\qooxdoo-0.8.1-sdk\tool\pylib\generator\Generator.py", line 1499, in _expandRegExps
      raise RuntimeError, "Expression gives no results. Malformed entry: %s" % entry
      RuntimeError: Expression gives no results. Malformed entry: custom.Application
  
    My custom/config.json has job/common/include defined as :
     "include" :
      [
        "custom.abc.MyApplication",
        "${QXTHEME}",
        "qx.legacy.theme.ClassicRoyale"
      ],

       In v0.8, this used to take precedence over qooxdoo-0.8-sdk\tool\data\config\base.json's (containing the source job) jobs/common/include:
      "include" :
      [
        "${QXTHEME}",
        "${APPLICATION}.Application"
      ],
   
    But, in v0.8.1, my include contains (doing generate.py -v souce tells me):
    include': [u'custom.abc.MyApplication',
              u'qx.theme.Modern',
              u'qx.legacy.theme.ClassicRoyale',
              u'custom.Application'],         <= ERROR code

    And this last line of include is the error.So, both my includes are getting combined instead of getting replaced. Is this a bug in v0.8.1 or am I missing any other setting in config.json ?
-- 
Amit Rana 
SpagoBI Consultant 
www.eng.it            www.spagoworld.org

------------------------------------------------------------------------------
This SF.net email is sponsored by:
SourcForge Community
SourceForge wants to tell your story.
http://p.sf.net/sfu/sf-spreadtheword
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
Reply | Threaded
Open this post in threaded view
|

Re: Moving from v0.8 SDK to v0.8.1 SDK - error in generate.py

Christian Schmidt
Hi Amit,

in 0.8.1 it is possible to combine jobs. If you don't want to combine
jobs, you have to use the "=" in the key value.

In your example you have to write:

"=include" : <<<< instead of "include"
      [
        "custom.abc.MyApplication",
        "${QXTHEME}",
        "qx.legacy.theme.ClassicRoyale"
      ],

For more details have a look at:
http://qooxdoo.org/documentation/0.8/generator_config_articles?s=override%20key#job_shadowing_and_partial_overriding

Cheers,
Chris

Amit Rana schrieb:

> Hi,
>
> I am able to run my application successfully using v0.8 SDK. Now, I
> wanted to test it using v0.8.1 and am some facing problems. I went
> through the online help and have some queries.
>
> 1.       1. I wanted to highlight one thing mentioned at :
> http://qooxdoo.org/documentation/0.8/setting_a_different_application_root.
> It says
>       "QOOXDOO_PATH" : "PATH_TO_FRAMEWORK_FOLDER",
>
>     I think this was true in v0.8. But in v0.8.1, it should just point
> to the SDK folder (containing the framework folder), else it gives an
> error.
>
>  2. When I call generate.py source, I get an error stating :
>
>       File "...\qooxdoo-0.8.1-sdk\tool\pylib\generator\Generator.py",
> line 1499, in _expandRegExps
>       raise RuntimeError, "Expression gives no results. Malformed
> entry: %s" % entry
>       RuntimeError: Expression gives no results. Malformed entry:
> custom.Application
>  
>     My custom/config.json has job/common/include defined as :
>      "include" :
>       [
>         "custom.abc.MyApplication",
>         "${QXTHEME}",
>         "qx.legacy.theme.ClassicRoyale"
>       ],
>
>        In v0.8, this used to take precedence over
> qooxdoo-0.8-sdk\tool\data\config\base.json's (containing the source
> job) jobs/common/include:
>       "include" :
>       [
>         "${QXTHEME}",
>         "${APPLICATION}.Application"
>       ],
>    
>     But, in v0.8.1, my include contains (doing generate.py -v souce
> tells me):
>     include': [u'custom.abc.MyApplication',
>               u'qx.theme.Modern',
>               u'qx.legacy.theme.ClassicRoyale',
>               u'custom.Application'],         _*<= ERROR code*_
>
>     And this last line of include is the error.So, both my includes
> are getting combined instead of getting replaced. Is this a bug in
> v0.8.1 or am I missing any other setting in config.json ?
> --
> Amit Rana
> SpagoBI Consultant
> www.eng.it            www.spagoworld.org
>  
> ------------------------------------------------------------------------
>
> ------------------------------------------------------------------------------
> This SF.net email is sponsored by:
> SourcForge Community
> SourceForge wants to tell your story.
> http://p.sf.net/sfu/sf-spreadtheword
> ------------------------------------------------------------------------
>
> _______________________________________________
> qooxdoo-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
>  


--
Christian Schmidt
Software Engineer
Core Development :: Web Technologies

1&1 Internet AG
Ernst-Frey-Str. 9
76135 Karlsruhe, Germany
http://www.1und1.de 

Amtsgericht Montabaur / HRB 6484
                                                       
Vorstände: Henning Ahlert, Ralph Dommermuth, Matthias Ehrlich, Thomas Gottschlich, Robert Hoffmann, Markus Huhn, Hans-Henning Kettler, Dr. Oliver Mauss, Jan Oetjen

Aufsichtsratsvorsitzender: Michael Scheeren


------------------------------------------------------------------------------
This SF.net email is sponsored by:
SourcForge Community
SourceForge wants to tell your story.
http://p.sf.net/sfu/sf-spreadtheword
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
Reply | Threaded
Open this post in threaded view
|

Re: Moving from v0.8 SDK to v0.8.1 SDK - error in generate.py

Amit Rana
Hi,

Thanks for the information. But, I already tried with this too and got
the same error.
Looks like the selective block merging feature is not working (for me).

--
Amit Rana
SpagoBI Consultant
www.eng.it            www.spagoworld.org


Christian Schmidt wrote:

> Hi Amit,
>
> in 0.8.1 it is possible to combine jobs. If you don't want to combine
> jobs, you have to use the "=" in the key value.
>
> In your example you have to write:
>
> "=include" : <<<< instead of "include"
>       [
>         "custom.abc.MyApplication",
>         "${QXTHEME}",
>         "qx.legacy.theme.ClassicRoyale"
>       ],
>
> For more details have a look at:
> http://qooxdoo.org/documentation/0.8/generator_config_articles?s=override%20key#job_shadowing_and_partial_overriding
>
> Cheers,
> Chris
>
> Amit Rana schrieb:
>  
>> Hi,
>>
>> I am able to run my application successfully using v0.8 SDK. Now, I
>> wanted to test it using v0.8.1 and am some facing problems. I went
>> through the online help and have some queries.
>>
>> 1.       1. I wanted to highlight one thing mentioned at :
>> http://qooxdoo.org/documentation/0.8/setting_a_different_application_root.
>> It says
>>       "QOOXDOO_PATH" : "PATH_TO_FRAMEWORK_FOLDER",
>>
>>     I think this was true in v0.8. But in v0.8.1, it should just point
>> to the SDK folder (containing the framework folder), else it gives an
>> error.
>>
>>  2. When I call generate.py source, I get an error stating :
>>
>>       File "...\qooxdoo-0.8.1-sdk\tool\pylib\generator\Generator.py",
>> line 1499, in _expandRegExps
>>       raise RuntimeError, "Expression gives no results. Malformed
>> entry: %s" % entry
>>       RuntimeError: Expression gives no results. Malformed entry:
>> custom.Application
>>  
>>     My custom/config.json has job/common/include defined as :
>>      "include" :
>>       [
>>         "custom.abc.MyApplication",
>>         "${QXTHEME}",
>>         "qx.legacy.theme.ClassicRoyale"
>>       ],
>>
>>        In v0.8, this used to take precedence over
>> qooxdoo-0.8-sdk\tool\data\config\base.json's (containing the source
>> job) jobs/common/include:
>>       "include" :
>>       [
>>         "${QXTHEME}",
>>         "${APPLICATION}.Application"
>>       ],
>>    
>>     But, in v0.8.1, my include contains (doing generate.py -v souce
>> tells me):
>>     include': [u'custom.abc.MyApplication',
>>               u'qx.theme.Modern',
>>               u'qx.legacy.theme.ClassicRoyale',
>>               u'custom.Application'],         _*<= ERROR code*_
>>
>>     And this last line of include is the error.So, both my includes
>> are getting combined instead of getting replaced. Is this a bug in
>> v0.8.1 or am I missing any other setting in config.json ?
>> --
>> Amit Rana
>> SpagoBI Consultant
>> www.eng.it            www.spagoworld.org
>>    

------------------------------------------------------------------------------
This SF.net email is sponsored by:
SourcForge Community
SourceForge wants to tell your story.
http://p.sf.net/sfu/sf-spreadtheword
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
Reply | Threaded
Open this post in threaded view
|

Re: Moving from v0.8 SDK to v0.8.1 SDK - error in generate.py

thron7
Amit,

run 'generate.py source-script -v', using the "=include" version in your
config, and post the console output up to and including the expanded job
map.

Thanks,
T.

Amit Rana wrote:
> Hi,
>
> Thanks for the information. But, I already tried with this too and got
> the same error.
> Looks like the selective block merging feature is not working (for me).
>
>  

------------------------------------------------------------------------------
This SF.net email is sponsored by:
SourcForge Community
SourceForge wants to tell your story.
http://p.sf.net/sfu/sf-spreadtheword
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
Reply | Threaded
Open this post in threaded view
|

Re: Moving from v0.8 SDK to v0.8.1 SDK - error in generate.py

Amit Rana
Hi,

I had done some changes on my own in config.json (which I thought would
work) but were actually not working (not including the "source-script"
job because it was same as in base.json). So, I took the exact copy as
given at :
http://qooxdoo.org/documentation/0.8/setting_a_different_application_root.

So, I just need 2 clarifications:

1. "QOOXDOO_PATH" : "PATH_TO_FRAMEWORK_FOLDER", // to SDK/framework (as mentioned)
 maybe I was wrong in my 1st mail mentioning it to set to just SDK.

2. What does "APPLICATION_URI" be set to (not mentioned on the web page) ?

Amit

thron7 wrote:

> Amit,
>
> run 'generate.py source-script -v', using the "=include" version in your
> config, and post the console output up to and including the expanded job
> map.
>
> Thanks,
> T.
>
> Amit Rana wrote:
>  
>> Hi,
>>
>> Thanks for the information. But, I already tried with this too and got
>> the same error.
>> Looks like the selective block merging feature is not working (for me).
>>
>>  
>>    

------------------------------------------------------------------------------
This SF.net email is sponsored by:
SourcForge Community
SourceForge wants to tell your story.
http://p.sf.net/sfu/sf-spreadtheword
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
Reply | Threaded
Open this post in threaded view
|

Re: Moving from v0.8 SDK to v0.8.1 SDK - error in generate.py

thron7
Both of your questions are answered in the 0.8.1 release notes.

T.

Amit Rana wrote:

> Hi,
>
> I had done some changes on my own in config.json (which I thought would
> work) but were actually not working (not including the "source-script"
> job because it was same as in base.json). So, I took the exact copy as
> given at :
> http://qooxdoo.org/documentation/0.8/setting_a_different_application_root.
>
> So, I just need 2 clarifications:
>
> 1. "QOOXDOO_PATH" : "PATH_TO_FRAMEWORK_FOLDER", // to SDK/framework (as mentioned)
>  maybe I was wrong in my 1st mail mentioning it to set to just SDK.
>
> 2. What does "APPLICATION_URI" be set to (not mentioned on the web page) ?
>
> Amit
>
> thron7 wrote:
>  
>> Amit,
>>
>> run 'generate.py source-script -v', using the "=include" version in your
>> config, and post the console output up to and including the expanded job
>> map.
>>
>> Thanks,
>> T.
>>
>> Amit Rana wrote:
>>  
>>    
>>> Hi,
>>>
>>> Thanks for the information. But, I already tried with this too and got
>>> the same error.
>>> Looks like the selective block merging feature is not working (for me).
>>>
>>>  
>>>    
>>>      
>
> ------------------------------------------------------------------------------
> This SF.net email is sponsored by:
> SourcForge Community
> SourceForge wants to tell your story.
> http://p.sf.net/sfu/sf-spreadtheword
> _______________________________________________
> qooxdoo-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
>
>
>  

------------------------------------------------------------------------------
This SF.net email is sponsored by:
SourcForge Community
SourceForge wants to tell your story.
http://p.sf.net/sfu/sf-spreadtheword
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
Reply | Threaded
Open this post in threaded view
|

Re: Moving from v0.8 SDK to v0.8.1 SDK - error in generate.py

Amit Rana
Hi,

This is in reference to my mail sometime back. I keep switching between
v0.8 and v0.8.1 because my application is working fine in v0.8 and
deployed and I am making it work in v0.8.1 to support future release.

When I run "generate.py translation" in v0.8.1 SDK (and not trunk
version), I get an error :
IOError: [Errno 2] No such file or directory: u'<my local
path>\\qooxdoo-0.8.1-sdk\\framework\\framework\\Manifest.json'  (notice
framework\framework which is incorrect)

I dug up and the issue is in base.json
(qooxdoo-0.8.1-sdk\tool\data\config\base.json) :
"jobs" :
  { ...
    "libraries" :
    {
        "library" :
      [
        {
          "manifest" : "${QOOXDOO_PATH}/framework/Manifest.json"
        },
       ....]
    },
    "common" :
    {
      "desc"    : "common settings for base.json jobs",

      "extend"  : ["libraries"],
       ....
}

Now, my "QOOXDOO_PATH" is over-ridden in config.json to point to
"../qooxdoo-0.8.1-sdk/framework",
and my config.json has :

"jobs" :
  {
      "common" :
    {
   
      "library" :
      [
        {
          "manifest" : "${QOOXDOO_PATH}/Manifest.json",
          "uri"      : "${QOOXDOO_URI}"
...

So, jobs\common\library of config.json should overwrite the same in
base.json but the jobs\libraries is not getting over-ridden, which is
causing the error.

Do, I need to add this in my config.json to make it work (I saw a
similar post at
http://n2.nabble.com/including-libraries-tp2255687p2255687.html) ? Was
this an issue in v0.8.1 SDK and resolved in trunk or its still present ?

regards
Amit

thron7 wrote:

> Both of your questions are answered in the 0.8.1 release notes.
>
> T.
>
> Amit Rana wrote:
>  
>> Hi,
>>
>> I had done some changes on my own in config.json (which I thought would
>> work) but were actually not working (not including the "source-script"
>> job because it was same as in base.json). So, I took the exact copy as
>> given at :
>> http://qooxdoo.org/documentation/0.8/setting_a_different_application_root.
>>
>> So, I just need 2 clarifications:
>>
>> 1. "QOOXDOO_PATH" : "PATH_TO_FRAMEWORK_FOLDER", // to SDK/framework (as mentioned)
>>  maybe I was wrong in my 1st mail mentioning it to set to just SDK.
>>
>> 2. What does "APPLICATION_URI" be set to (not mentioned on the web page) ?
>>
>> Amit
>>
>> thron7 wrote:
>>  
>>    
>>> Amit,
>>>
>>> run 'generate.py source-script -v', using the "=include" version in your
>>> config, and post the console output up to and including the expanded job
>>> map.
>>>
>>> Thanks,
>>> T.
>>>
>>> Amit Rana wrote:
>>>  
>>>    
>>>      
>>>> Hi,
>>>>
>>>> Thanks for the information. But, I already tried with this too and got
>>>> the same error.
>>>> Looks like the selective block merging feature is not working (for me).
>>>>        

------------------------------------------------------------------------------
Open Source Business Conference (OSBC), March 24-25, 2009, San Francisco, CA
-OSBC tackles the biggest issue in open source: Open Sourcing the Enterprise
-Strategies to boost innovation and cut costs with open source participation
-Receive a $600 discount off the registration fee with the source code: SFAD
http://p.sf.net/sfu/XcvMzF8H
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
Reply | Threaded
Open this post in threaded view
|

Re: Moving from v0.8 SDK to v0.8.1 SDK - error in generate.py

Amit Rana
Just a quick update.

Overriding in config.json also doesn't help. So, I had to change the
base.json.
Also, my translation job in config.json defined as :

"translation" :
    {
      "extend" : ["common", "appconf::translation"]
    }

did not work as it gave error saying "Malformed entry :
mycustom.Application". And, when I copy-paste the job from base.json
into config.json, it worked. So, looks like merging of jobs in v0.8.1 is
not working well.

I know this because earlier I had to set even my source job in
config.json as :
"source" :
    {
      "run" : ["source-script"]
    },
   
    // adjusted job to set another application root
    "source-script" :
    {
      "extend" : ["common"],
 
      "compile-source" :
      {
        "file" : "${ROOT}/source/script/${APPLICATION}.js",
        "locales" : "${LOCALES}",
        "root" : "source"
      }
    },

which is same as in base.json instead of extending it as it did not work.

So, looks likes an issue in v0.8.1 SDK. I cannot use the trunk version
as I need to work with the latest release version (project requirements
:-( )

Amit

Amit Rana wrote:

> Hi,
>
> This is in reference to my mail sometime back. I keep switching
> between v0.8 and v0.8.1 because my application is working fine in v0.8
> and deployed and I am making it work in v0.8.1 to support future release.
>
> When I run "generate.py translation" in v0.8.1 SDK (and not trunk
> version), I get an error :
> IOError: [Errno 2] No such file or directory: u'<my local
> path>\\qooxdoo-0.8.1-sdk\\framework\\framework\\Manifest.json'  
> (notice framework\framework which is incorrect)
>
> I dug up and the issue is in base.json
> (qooxdoo-0.8.1-sdk\tool\data\config\base.json) :
> "jobs" :
>  { ...
>    "libraries" :
>    {
>        "library" :
>      [
>        {
>          "manifest" : "${QOOXDOO_PATH}/framework/Manifest.json"
>        },
>       ....]
>    },
>    "common" :
>    {
>      "desc"    : "common settings for base.json jobs",
>
>      "extend"  : ["libraries"],
>       ....
> }
>
> Now, my "QOOXDOO_PATH" is over-ridden in config.json to point to
> "../qooxdoo-0.8.1-sdk/framework",
> and my config.json has :
>
> "jobs" :
>  {
>      "common" :
>    {
>        "library" :
>      [
>        {
>          "manifest" : "${QOOXDOO_PATH}/Manifest.json",
>          "uri"      : "${QOOXDOO_URI}"
> ...
>
> So, jobs\common\library of config.json should overwrite the same in
> base.json but the jobs\libraries is not getting over-ridden, which is
> causing the error.
>
> Do, I need to add this in my config.json to make it work (I saw a
> similar post at
> http://n2.nabble.com/including-libraries-tp2255687p2255687.html) ? Was
> this an issue in v0.8.1 SDK and resolved in trunk or its still present ?
>
> regards
> Amit
>
> thron7 wrote:
>> Both of your questions are answered in the 0.8.1 release notes.
>>
>> T.
>>
>> Amit Rana wrote:
>>  
>>> Hi,
>>>
>>> I had done some changes on my own in config.json (which I thought
>>> would work) but were actually not working (not including the
>>> "source-script" job because it was same as in base.json). So, I took
>>> the exact copy as given at :
>>> http://qooxdoo.org/documentation/0.8/setting_a_different_application_root.
>>>
>>>
>>> So, I just need 2 clarifications:
>>>
>>> 1. "QOOXDOO_PATH" : "PATH_TO_FRAMEWORK_FOLDER", // to SDK/framework
>>> (as mentioned)
>>>  maybe I was wrong in my 1st mail mentioning it to set to just SDK.
>>>
>>> 2. What does "APPLICATION_URI" be set to (not mentioned on the web
>>> page) ?
>>>
>>> Amit
>>>
>>> thron7 wrote:
>>>      
>>>> Amit,
>>>>
>>>> run 'generate.py source-script -v', using the "=include" version in
>>>> your config, and post the console output up to and including the
>>>> expanded job map.
>>>>
>>>> Thanks,
>>>> T.
>>>>
>>>> Amit Rana wrote:
>>>>            
>>>>> Hi,
>>>>>
>>>>> Thanks for the information. But, I already tried with this too and
>>>>> got the same error.
>>>>> Looks like the selective block merging feature is not working (for
>>>>> me).
>>>>>        
>

------------------------------------------------------------------------------
Open Source Business Conference (OSBC), March 24-25, 2009, San Francisco, CA
-OSBC tackles the biggest issue in open source: Open Sourcing the Enterprise
-Strategies to boost innovation and cut costs with open source participation
-Receive a $600 discount off the registration fee with the source code: SFAD
http://p.sf.net/sfu/XcvMzF8H
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
Reply | Threaded
Open this post in threaded view
|

Re: Moving from v0.8 SDK to v0.8.1 SDK - error in generate.py

Thomas Herchenroeder
In reply to this post by Amit Rana


Amit Rana wrote:

> Hi,
>
> This is in reference to my mail sometime back. I keep switching between
> v0.8 and v0.8.1 because my application is working fine in v0.8 and
> deployed and I am making it work in v0.8.1 to support future release.
>
> When I run "generate.py translation" in v0.8.1 SDK (and not trunk
> version), I get an error :
> IOError: [Errno 2] No such file or directory: u'<my local
> path>\\qooxdoo-0.8.1-sdk\\framework\\framework\\Manifest.json'  (notice
> framework\framework which is incorrect)
>
> I dug up and the issue is in base.json
> (qooxdoo-0.8.1-sdk\tool\data\config\base.json) :
> "jobs" :
>   { ...
>     "libraries" :
>     {
>         "library" :
>       [
>         {
>           "manifest" : "${QOOXDOO_PATH}/framework/Manifest.json"
>         },
>        ....]
>     },
>     "common" :
>     {
>       "desc"    : "common settings for base.json jobs",
>
>       "extend"  : ["libraries"],
>        ....
> }
>
> Now, my "QOOXDOO_PATH" is over-ridden in config.json to point to
> "../qooxdoo-0.8.1-sdk/framework",
>  

which is wrong - you still don't heed the release notes :-(.

t.

> and my config.json has :
>
> "jobs" :
>   {
>       "common" :
>     {
>    
>       "library" :
>       [
>         {
>           "manifest" : "${QOOXDOO_PATH}/Manifest.json",
>           "uri"      : "${QOOXDOO_URI}"
> ...
>
> So, jobs\common\library of config.json should overwrite the same in
> base.json but the jobs\libraries is not getting over-ridden, which is
> causing the error.
>
> Do, I need to add this in my config.json to make it work (I saw a
> similar post at
> http://n2.nabble.com/including-libraries-tp2255687p2255687.html) ? Was
> this an issue in v0.8.1 SDK and resolved in trunk or its still present ?
>
> regards
> Amit
>
> thron7 wrote:
>  
>> Both of your questions are answered in the 0.8.1 release notes.
>>
>> T.
>>
>> Amit Rana wrote:
>>  
>>    
>>> Hi,
>>>
>>> I had done some changes on my own in config.json (which I thought would
>>> work) but were actually not working (not including the "source-script"
>>> job because it was same as in base.json). So, I took the exact copy as
>>> given at :
>>> http://qooxdoo.org/documentation/0.8/setting_a_different_application_root.
>>>
>>> So, I just need 2 clarifications:
>>>
>>> 1. "QOOXDOO_PATH" : "PATH_TO_FRAMEWORK_FOLDER", // to SDK/framework (as mentioned)
>>>  maybe I was wrong in my 1st mail mentioning it to set to just SDK.
>>>
>>> 2. What does "APPLICATION_URI" be set to (not mentioned on the web page) ?
>>>
>>> Amit
>>>
>>> thron7 wrote:
>>>  
>>>    
>>>      
>>>> Amit,
>>>>
>>>> run 'generate.py source-script -v', using the "=include" version in your
>>>> config, and post the console output up to and including the expanded job
>>>> map.
>>>>
>>>> Thanks,
>>>> T.
>>>>
>>>> Amit Rana wrote:
>>>>  
>>>>    
>>>>      
>>>>        
>>>>> Hi,
>>>>>
>>>>> Thanks for the information. But, I already tried with this too and got
>>>>> the same error.
>>>>> Looks like the selective block merging feature is not working (for me).
>>>>>        
>>>>>          
>
> ------------------------------------------------------------------------------
> Open Source Business Conference (OSBC), March 24-25, 2009, San Francisco, CA
> -OSBC tackles the biggest issue in open source: Open Sourcing the Enterprise
> -Strategies to boost innovation and cut costs with open source participation
> -Receive a $600 discount off the registration fee with the source code: SFAD
> http://p.sf.net/sfu/XcvMzF8H
> _______________________________________________
> qooxdoo-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
>
>
>  

------------------------------------------------------------------------------
Open Source Business Conference (OSBC), March 24-25, 2009, San Francisco, CA
-OSBC tackles the biggest issue in open source: Open Sourcing the Enterprise
-Strategies to boost innovation and cut costs with open source participation
-Receive a $600 discount off the registration fee with the source code: SFAD
http://p.sf.net/sfu/XcvMzF8H
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel