GraydientTheme and RetroTheme on Qooxdoo 5.0.1 API

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

GraydientTheme and RetroTheme on Qooxdoo 5.0.1 API

Peter Caffin
Hi guys,

I've been trying out a couple of the other themes in Contribs and
spotted a couple of bugs in GraydientTheme and all three variants of
RetroTheme.

   qx.ui.form.MenuButton - Button appearance missing (looks like a
label, but can be clicked).

   qx.ui.form.DateField - doesn't display the calendar icon.

Cheers.

------------------------------------------------------------------------------
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
Reply | Threaded
Open this post in threaded view
|

Re: GraydientTheme and RetroTheme on Qooxdoo 5.0.1 API

N. Schröder
Hello Pete,

How did you get any of these themes running on qx 5.x? I didn't upgrade
them since qx 3.0 and they should'nt even be generated properly in one
of the recent qooxdoo versions.

But, as it happens, I'm currently porting the GraydientTheme and will
hopefully be finished by Sunday.

Cheers,

   Norbert


Am 15.09.2015 um 22:39 schrieb Peter Caffin:

> Hi guys,
>
> I've been trying out a couple of the other themes in Contribs and
> spotted a couple of bugs in GraydientTheme and all three variants of
> RetroTheme.
>
>     qx.ui.form.MenuButton - Button appearance missing (looks like a
> label, but can be clicked).
>
>     qx.ui.form.DateField - doesn't display the calendar icon.
>
> Cheers.
>
> ------------------------------------------------------------------------------
> _______________________________________________
> qooxdoo-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel


------------------------------------------------------------------------------
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
Reply | Threaded
Open this post in threaded view
|

Re: GraydientTheme and RetroTheme on Qooxdoo 5.0.1 API

fritz
Go, Norbert, go ... ;-)

On Tue, 15 Sep 2015, Norbert Schröder wrote:

> How did you get any of these themes running on qx 5.x? I didn't upgrade
> them since qx 3.0 and they should'nt even be generated properly in one
> of the recent qooxdoo versions.
>
> But, as it happens, I'm currently porting the GraydientTheme and will
> hopefully be finished by Sunday.

--
Oetiker+Partner AG              tel: +41 62 775 9903 (direct)
Fritz Zaucker                        +41 62 775 9900 (switch board)
Aarweg 15                            +41 79 675 0630 (mobile)
CH-4600 Olten                   fax: +41 62 775 9905
Schweiz                         web: www.oetiker.ch
------------------------------------------------------------------------------

_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
Reply | Threaded
Open this post in threaded view
|

Re: GraydientTheme and RetroTheme on Qooxdoo 5.0.1 API

N. Schröder
Hi Fritz,

You're working late, too, aren't you? ;-)


Am 15.09.2015 um 23:13 schrieb Fritz Zaucker:
Go, Norbert, go ... ;-)

On Tue, 15 Sep 2015, Norbert Schröder wrote:

How did you get any of these themes running on qx 5.x? I didn't upgrade
them since qx 3.0 and they should'nt even be generated properly in one
of the recent qooxdoo versions.

But, as it happens, I'm currently porting the GraydientTheme and will
hopefully be finished by Sunday.



------------------------------------------------------------------------------


_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel


------------------------------------------------------------------------------

_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
Reply | Threaded
Open this post in threaded view
|

Re: GraydientTheme and RetroTheme on Qooxdoo 5.0.1 API

Peter Caffin
In reply to this post by N. Schröder
Hi Norbert,

I can't explain it. It might be something in the SDK changes to 5.0.1
over 5.0.

I wasn't able to use them before the upgrade, but tried again later on a
whim after grabbing the new SDK and it worked.


On 16/09/2015 5:09 am, Norbert Schröder wrote:

> Hello Pete,
>
> How did you get any of these themes running on qx 5.x? I didn't upgrade
> them since qx 3.0 and they should'nt even be generated properly in one
> of the recent qooxdoo versions.
>
> But, as it happens, I'm currently porting the GraydientTheme and will
> hopefully be finished by Sunday.
>
> Cheers,
>
>     Norbert

------------------------------------------------------------------------------
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
Reply | Threaded
Open this post in threaded view
|

Re: GraydientTheme and RetroTheme on Qooxdoo 5.0.1 API

N. Schröder
Hello Pete,

I'll give both themes a try with 5.0.1, probably tomorrow (GMT +1).

Norbert


Am 15.09.2015 um 23:37 schrieb Peter Caffin:
> Hi Norbert,
>
> I can't explain it. It might be something in the SDK changes to 5.0.1
> over 5.0.
>
> I wasn't able to use them before the upgrade, but tried again later on a
> whim after grabbing the new SDK and it worked.
>
>

------------------------------------------------------------------------------
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
Reply | Threaded
Open this post in threaded view
|

Re: GraydientTheme and RetroTheme on Qooxdoo 5.0.1 API

N. Schröder
In reply to this post by Peter Caffin
Hello Pete,

I just tried the GraydientTheme with qx 5.0.1. The little sample application got generated with only a few warnings and runs without problems, as long as I dont't use sliders or scrollbars. The theme uses grid decorators to display these widgets and grid decorators are the only ones that don't work anymore in qx 3.0+ without manual adjustments in the source code.

If you dont't need sliders or scrollbars, you won't encounter serious problems with these themes. Otherwise, you'll have to wait until I've ported them.

Cheers,

  Norbert


Peter Caffin schrieb am 15.09.2015 23:37:

> Hi Norbert,
>
> I can't explain it. It might be something in the SDK changes to 5.0.1
> over 5.0.
>
> I wasn't able to use them before the upgrade, but tried again later on a
> whim after grabbing the new SDK and it worked.
>
>
> On 16/09/2015 5:09 am, Norbert Schröder wrote:
>> Hello Pete,
>>
>> How did you get any of these themes running on qx 5.x? I didn't upgrade
>> them since qx 3.0 and they should'nt even be generated properly in one
>> of the recent qooxdoo versions.
>>
>> But, as it happens, I'm currently porting the GraydientTheme and will
>> hopefully be finished by Sunday.
>>
>> Cheers,
>>
>>     Norbert
>
> ------------------------------------------------------------------------------
> _______________________________________________
> qooxdoo-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
>


------------------------------------------------------------------------------
Monitor Your Dynamic Infrastructure at Any Scale With Datadog!
Get real-time metrics from all of your servers, apps and tools
in one place.
SourceForge users - Click here to start your Free Trial of Datadog now!
http://pubads.g.doubleclick.net/gampad/clk?id=241902991&iu=/4140
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
Reply | Threaded
Open this post in threaded view
|

Re: GraydientTheme and RetroTheme on Qooxdoo 5.0.1 API

Peter Caffin
Hi Norbert,

Glad it's not just me it worked for :)

Thanks again for all you're doing to update these themes. Nothing's
urgent for me personally. I was just trying them to see how they looked.


On 16/09/2015 11:48 pm, Norbert Schroeder wrote:

> Hello Pete,
>
> I just tried the GraydientTheme with qx 5.0.1. The little sample application got generated with only a few warnings and runs without problems, as long as I dont't use sliders or scrollbars. The theme uses grid decorators to display these widgets and grid decorators are the only ones that don't work anymore in qx 3.0+ without manual adjustments in the source code.
>
> If you dont't need sliders or scrollbars, you won't encounter serious problems with these themes. Otherwise, you'll have to wait until I've ported them.
>
> Cheers,
>
>    Norbert
>
>
> Peter Caffin schrieb am 15.09.2015 23:37:
>
>> Hi Norbert,
>>
>> I can't explain it. It might be something in the SDK changes to 5.0.1
>> over 5.0.
>>
>> I wasn't able to use them before the upgrade, but tried again later on a
>> whim after grabbing the new SDK and it worked.



------------------------------------------------------------------------------
Monitor Your Dynamic Infrastructure at Any Scale With Datadog!
Get real-time metrics from all of your servers, apps and tools
in one place.
SourceForge users - Click here to start your Free Trial of Datadog now!
http://pubads.g.doubleclick.net/gampad/clk?id=241902991&iu=/4140
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel