Errors running compiled demobrowser

classic Classic list List threaded Threaded
7 messages Options
dev
Reply | Threaded
Open this post in threaded view
|

Errors running compiled demobrowser

dev
Hi!

I get the following error in Firebug running demobrowser locally after compilation:

TypeError: tmap.sort is not a function
tmap.sort(topsort);
TreeDat...1579504 (line 126, col 6)

it seems as if the data structure can not be handled that way with adding a sort on it.

Additionally, I get:

008645 qx.bom.webfonts.WebFont[27-0]: WebFont JosefinSlab was not applied, perhaps the source file could not be loaded.
Native....1155325 (line 59)

Is the browser blocking the access of the file?

Anyone knows the reasons of the errors?

Best Regards,
Stefan

------------------------------------------------------------------------------
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
Reply | Threaded
Open this post in threaded view
|

Re: Errors running compiled demobrowser

Daniel Wagner
Administrator
Hi Stefan,

yes, if you're loading the demobrowser from the file system, the browser
will restrict access to some external files which leads to these errors.
If you don't already have a web server running, you can use

python -m SimpleHTTPServer

to start one from the shell and load the application through it. Note
that you'll have to start the server in the root dir of your qooxdoo SDK
or repo clone if you want to use the source version of any app.

Regards,
Daniel

On 11.08.2014 16:10, [hidden email] wrote:

> Hi!
>
> I get the following error in Firebug running demobrowser locally after compilation:
>
> TypeError: tmap.sort is not a function
> tmap.sort(topsort);
> TreeDat...1579504 (line 126, col 6)
>
> it seems as if the data structure can not be handled that way with adding a sort on it.
>
> Additionally, I get:
>
> 008645 qx.bom.webfonts.WebFont[27-0]: WebFont JosefinSlab was not applied, perhaps the source file could not be loaded.
> Native....1155325 (line 59)
>
> Is the browser blocking the access of the file?
>
> Anyone knows the reasons of the errors?
>
> Best Regards,
> Stefan
>
> ------------------------------------------------------------------------------
> _______________________________________________
> qooxdoo-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
>

------------------------------------------------------------------------------
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
dev
Reply | Threaded
Open this post in threaded view
|

Re: Errors running compiled demobrowser

dev
Thanks Daniel,

It was what I supposed. Now flawless...

Stefan

> Hi Stefan,
>
> yes, if you're loading the demobrowser from the file system, the browser
> will restrict access to some external files which leads to these errors.
> If you don't already have a web server running, you can use
>
> python -m SimpleHTTPServer
>
> to start one from the shell and load the application through it. Note
> that you'll have to start the server in the root dir of your qooxdoo SDK
> or repo clone if you want to use the source version of any app.
>
> Regards,
> Daniel
>
> On 11.08.2014 16:10, [hidden email] wrote:
>> Hi!
>>
>> I get the following error in Firebug running demobrowser locally after compilation:
>>
>> TypeError: tmap.sort is not a function
>> tmap.sort(topsort);
>> TreeDat...1579504 (line 126, col 6)
>>
>> it seems as if the data structure can not be handled that way with adding a sort on it.
>>
>> Additionally, I get:
>>
>> 008645 qx.bom.webfonts.WebFont[27-0]: WebFont JosefinSlab was not applied, perhaps the source file could not be loaded.
>> Native....1155325 (line 59)
>>
>> Is the browser blocking the access of the file?
>>
>> Anyone knows the reasons of the errors?
>>
>> Best Regards,
>> Stefan
>>
>> ------------------------------------------------------------------------------
>> _______________________________________________
>> qooxdoo-devel mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
>>
>
> ------------------------------------------------------------------------------
> _______________________________________________
> qooxdoo-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel



------------------------------------------------------------------------------
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
Reply | Threaded
Open this post in threaded view
|

Re: Errors running compiled demobrowser

halcwb
Running from IIS when running my test suite I get:

"NetworkError: 404 Not Found - http://localhost/genpres/mobile/genpres/test/resource/qx/decoration/Indigo/font/JosefinSlab-SemiBold.woff"

However, the file is there the rest of the test suite loads fine. Also, it is in the path of the website root.
Reply | Threaded
Open this post in threaded view
|

Re: Errors running compiled demobrowser

Loren Schlomer-2
I know very little about IIS, so this is probably just a shot in the
dark...  but is there a security policy in IIS preventing .woff files
from being served?  That might be the first place I would look, if
everything from else from that relative path is loading correctly.



On 2014-12-23 05:32, halcwb wrote:

> Running from IIS when running my test suite I get:
>
> "NetworkError: 404 Not Found -
> http://localhost/genpres/mobile/genpres/test/resource/qx/decoration/Indigo/font/JosefinSlab-SemiBold.woff"
>
> However, the file is there the rest of the test suite loads fine. Also,
> it
> is in the path of the website root.
>
>
>
> --
> View this message in context:
> http://qooxdoo.678.n2.nabble.com/Errors-running-compiled-demobrowser-tp7586052p7586510.html
> Sent from the qooxdoo mailing list archive at Nabble.com.
>
> ------------------------------------------------------------------------------
> Dive into the World of Parallel Programming! The Go Parallel Website,
> sponsored by Intel and developed in partnership with Slashdot Media, is
> your
> hub for all things parallel software development, from weekly thought
> leadership blogs to news, videos, case studies, tutorials and more.
> Take a
> look and join the conversation now. http://goparallel.sourceforge.net
> _______________________________________________
> qooxdoo-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel

------------------------------------------------------------------------------
Dive into the World of Parallel Programming! The Go Parallel Website,
sponsored by Intel and developed in partnership with Slashdot Media, is your
hub for all things parallel software development, from weekly thought
leadership blogs to news, videos, case studies, tutorials and more. Take a
look and join the conversation now. http://goparallel.sourceforge.net
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
Reply | Threaded
Open this post in threaded view
|

Re: Errors running compiled demobrowser

halcwb
Loren Schlomer-2 wrote
I know very little about IIS, so this is probably just a shot in the
dark...  but is there a security policy in IIS preventing .woff files
from being served?  That might be the first place I would look, if
everything from else from that relative path is loading correctly.

Ah you just beat me before it. Indeed it was just an IIS config thing, I had to add the MIME woff type, otherwise IIS was unwilling to serve something it doesn't know;-)



On 2014-12-23 05:32, halcwb wrote:
> Running from IIS when running my test suite I get:
>
> "NetworkError: 404 Not Found -
> http://localhost/genpres/mobile/genpres/test/resource/qx/decoration/Indigo/font/JosefinSlab-SemiBold.woff"
>
> However, the file is there the rest of the test suite loads fine. Also,
> it
> is in the path of the website root.
>
>
>
> --
> View this message in context:
> http://qooxdoo.678.n2.nabble.com/Errors-running-compiled-demobrowser-tp7586052p7586510.html
> Sent from the qooxdoo mailing list archive at Nabble.com.
>
> ------------------------------------------------------------------------------
> Dive into the World of Parallel Programming! The Go Parallel Website,
> sponsored by Intel and developed in partnership with Slashdot Media, is
> your
> hub for all things parallel software development, from weekly thought
> leadership blogs to news, videos, case studies, tutorials and more.
> Take a
> look and join the conversation now. http://goparallel.sourceforge.net
> _______________________________________________
> qooxdoo-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel

------------------------------------------------------------------------------
Dive into the World of Parallel Programming! The Go Parallel Website,
sponsored by Intel and developed in partnership with Slashdot Media, is your
hub for all things parallel software development, from weekly thought
leadership blogs to news, videos, case studies, tutorials and more. Take a
look and join the conversation now. http://goparallel.sourceforge.net
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
Reply | Threaded
Open this post in threaded view
|

Re: Errors running compiled demobrowser

Ivan Pogorelov
Hi, 
there's no mime for the extension. You have to add mime to Web.config (or via IIS manager):

<system.webServer>
<
staticContent> <mimeMap fileExtension=".woff" mimeType="application/font-woff" /> </staticContent> </system.webServer>

The best regards,
Ivan

On Wed, Dec 24, 2014 at 2:05 AM, halcwb <[hidden email]> wrote:
Loren Schlomer-2 wrote
> I know very little about IIS, so this is probably just a shot in the
> dark...  but is there a security policy in IIS preventing .woff files
> from being served?  That might be the first place I would look, if
> everything from else from that relative path is loading correctly.
>
> Ah you just beat me before it. Indeed it was just an IIS config thing, I
> had to add the MIME woff type, otherwise IIS was unwilling to serve
> something it doesn't know;-)
>
>
>
> On 2014-12-23 05:32, halcwb wrote:
>> Running from IIS when running my test suite I get:
>>
>> "NetworkError: 404 Not Found -
>> http://localhost/genpres/mobile/genpres/test/resource/qx/decoration/Indigo/font/JosefinSlab-SemiBold.woff"
>>
>> However, the file is there the rest of the test suite loads fine. Also,
>> it
>> is in the path of the website root.
>>
>>
>>
>> --
>> View this message in context:
>> http://qooxdoo.678.n2.nabble.com/Errors-running-compiled-demobrowser-tp7586052p7586510.html
>> Sent from the qooxdoo mailing list archive at Nabble.com.
>>
>> ------------------------------------------------------------------------------
>> Dive into the World of Parallel Programming! The Go Parallel Website,
>> sponsored by Intel and developed in partnership with Slashdot Media, is
>> your
>> hub for all things parallel software development, from weekly thought
>> leadership blogs to news, videos, case studies, tutorials and more.
>> Take a
>> look and join the conversation now. http://goparallel.sourceforge.net
>> _______________________________________________
>> qooxdoo-devel mailing list
>>

> qooxdoo-devel@.sourceforge

>> https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
>
> ------------------------------------------------------------------------------
> Dive into the World of Parallel Programming! The Go Parallel Website,
> sponsored by Intel and developed in partnership with Slashdot Media, is
> your
> hub for all things parallel software development, from weekly thought
> leadership blogs to news, videos, case studies, tutorials and more. Take a
> look and join the conversation now. http://goparallel.sourceforge.net
> _______________________________________________
> qooxdoo-devel mailing list

> qooxdoo-devel@.sourceforge

> https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel





--
View this message in context: http://qooxdoo.678.n2.nabble.com/Errors-running-compiled-demobrowser-tp7586052p7586512.html
Sent from the qooxdoo mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Dive into the World of Parallel Programming! The Go Parallel Website,
sponsored by Intel and developed in partnership with Slashdot Media, is your
hub for all things parallel software development, from weekly thought
leadership blogs to news, videos, case studies, tutorials and more. Take a
look and join the conversation now. http://goparallel.sourceforge.net
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel


------------------------------------------------------------------------------
Dive into the World of Parallel Programming! The Go Parallel Website,
sponsored by Intel and developed in partnership with Slashdot Media, is your
hub for all things parallel software development, from weekly thought
leadership blogs to news, videos, case studies, tutorials and more. Take a
look and join the conversation now. http://goparallel.sourceforge.net
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel