Error: The theme to use is not available: qx.theme.Modern

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Error: The theme to use is not available: qx.theme.Modern

Gonath
This post has NOT been accepted by the mailing list yet.
This post was updated on .
Hi,

I'm testing Qooxdoo on a new server and my code doesn't work. i had no problem on other system.

I'm just trying something easy like this :


qx.Class.define("optime.Application",{
  extend : qx.application.Standalone,

  /*
  *****************************************************************************
     MEMBERS
  *****************************************************************************
  */

  members :
  {
    /**
     * This method contains the initial application code and gets called
     * during startup of the application
     */
    main : function()
    {
      // Call super class
      this.base(arguments);

      // Enable logging in debug variant
      if (qx.core.Environment.get("qx.debug"))
      {
        // support native logging capabilities, e.g. Firebug for Firefox
        qx.log.appender.Native;
        // support additional cross-browser console. Press F7 to toggle visibility
        qx.log.appender.Console;
      }

      /*
      -------------------------------------------------------------------------
        Below is your actual application code...
      -------------------------------------------------------------------------
      */
      // container layout
                  var layout = new qx.ui.layout.VBox();
               
                  // main container
                  var mainContainer = new qx.ui.container.Composite(layout);
                  this.getRoot().add(mainContainer, { edge : 0 });
    }
  }
});


without any change on the theme, but I obtain always the same error :
"Error: The theme to use is not available: qx.theme.Modern"

Anybody to help me ?

Thanks in advance,

Gonath
Reply | Threaded
Open this post in threaded view
|

Re: Error: The theme to use is not available: qx.theme.Modern

Gonath
This post has NOT been accepted by the mailing list yet.
ok I found the error.

I create a project :

python create-application.py -n myName -t native...

I only change native to desktop...

Sorry !