Button Events missing: Qooxdoo 5.0.1 with Edge Browser 20.10240

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Button Events missing: Qooxdoo 5.0.1 with Edge Browser 20.10240

Marcel Ruff-3
Hi,

first of all thank you for the new qooxdoo 5.0.1!

I'm running Qooxdoo 5.0.1 desktop with Microsoft Internet Explorer Edge Browser 20.10240 inside VirtualBox on Windows 10.

When clicking buttons etc on the main page all clicks react fine.

When opening a qx.ui.window.Window with some controls inside
the clicks don't react (eg. Button, SelectBox, Tabs etc).

The mouse over is recognized (theme changes) and when
I hit enter, the action starts, but the clicks of the mouse are ignored.

When installing a firefox or a google chrome into this Windows 10 all works fine.

Your demo on
http://demo.qooxdoo.org/current/widgetbrowser/
works fine.


What could be the reason for this?

Thank you
Marcel

------------------------------------------------------------------------------

_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
Reply | Threaded
Open this post in threaded view
|

Re: Button Events missing: Qooxdoo 5.0.1 with Edge Browser 20.10240

oetiker


On 16.09.2015, at 00:27, Marcel Ruff <[hidden email]> wrote:

Hi,

first of all thank you for the new qooxdoo 5.0.1!

I'm running Qooxdoo 5.0.1 desktop with Microsoft Internet Explorer Edge Browser 20.10240 inside VirtualBox on Windows 10.

When clicking buttons etc on the main page all clicks react fine.

When opening a qx.ui.window.Window with some controls inside
the clicks don't react (eg. Button, SelectBox, Tabs etc).


try stripping down your code to just the window and some controlls

cheers


The mouse over is recognized (theme changes) and when
I hit enter, the action starts, but the clicks of the mouse are ignored.

When installing a firefox or a google chrome into this Windows 10 all works fine.

Your demo on
http://demo.qooxdoo.org/current/widgetbrowser/
works fine.


What could be the reason for this?

Thank you
Marcel
------------------------------------------------------------------------------
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel

------------------------------------------------------------------------------
Monitor Your Dynamic Infrastructure at Any Scale With Datadog!
Get real-time metrics from all of your servers, apps and tools
in one place.
SourceForge users - Click here to start your Free Trial of Datadog now!
http://pubads.g.doubleclick.net/gampad/clk?id=241902991&iu=/4140
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
Reply | Threaded
Open this post in threaded view
|

Re: Button Events missing: Qooxdoo 5.0.1 with Edge Browser 20.10240

Marcel Ruff-3
Thank you, that helped finding the problem.

We had some old code

    // supportWindowMoveOnTouchDevices
      this.addListener("touchstart", this._onMovePointerDown, this);
      this.addListener("touchend", this._onMovePointerUp, this);
      this.addListener("touchmove", this._onMovePointerMove, this);
    ....

which caused the problem, removing the above and all works fine.

Marcel


On 16.09.2015 07:52, Tobias Oetiker wrote:


On 16.09.2015, at 00:27, Marcel Ruff <[hidden email]> wrote:

Hi,

first of all thank you for the new qooxdoo 5.0.1!

I'm running Qooxdoo 5.0.1 desktop with Microsoft Internet Explorer Edge Browser 20.10240 inside VirtualBox on Windows 10.

When clicking buttons etc on the main page all clicks react fine.

When opening a qx.ui.window.Window with some controls inside
the clicks don't react (eg. Button, SelectBox, Tabs etc).


try stripping down your code to just the window and some controlls

cheers


The mouse over is recognized (theme changes) and when
I hit enter, the action starts, but the clicks of the mouse are ignored.

When installing a firefox or a google chrome into this Windows 10 all works fine.

Your demo on
http://demo.qooxdoo.org/current/widgetbrowser/
works fine.


What could be the reason for this?

Thank you
Marcel
------------------------------------------------------------------------------
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel


------------------------------------------------------------------------------
Monitor Your Dynamic Infrastructure at Any Scale With Datadog!
Get real-time metrics from all of your servers, apps and tools
in one place.
SourceForge users - Click here to start your Free Trial of Datadog now!
http://pubads.g.doubleclick.net/gampad/clk?id=241902991&iu=/4140


_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel


------------------------------------------------------------------------------

_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel