Build / Source differences

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

Build / Source differences

Cajus Pollmeier
Hi,

I'm playing around with qx 2.0 and found my browser stating:

002930 Error in the 'Appearance' queue:TypeError: Cannot read property
'basename' of undefined

when using the source target. Some styles are broken when trying to display
the it in the browser (i.e. a tooltip is missing the borders, the window has
no background).

If I run a 'build' these errors are gone and the rendering looks fine.

In [1] you can find a source.png and the build.png to see how the rendering
looks in chrome. The (playing around state) source is in cute.tgz.

Any ideas what's wrong here?

Thanks,
Cajus

[1]
https://ferdi.naasa.net/oc/public.php?service=files&token=9bae9a7535dbd169f5e6c10f23d19edc37d6dad9&file=/qx

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel

signature.asc (197 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Build / Source differences

MartinWittemann
Administrator
Hey,
seems like the link is broken. :(
But still, your issue sounds strange. Usually, the build version breaks applications and does not heal them. ;) But I can't tell you much, only that we have never heard of such an Issue and we should check out whats the reason. Do you have a custom theme based on a qooxdoo theme? Maybe some keys in our theme changed and you use them in your application?
Regards,
Martin


Am 03.07.2012 um 10:46 schrieb Cajus Pollmeier:

> Hi,
>
> I'm playing around with qx 2.0 and found my browser stating:
>
> 002930 Error in the 'Appearance' queue:TypeError: Cannot read property
> 'basename' of undefined
>
> when using the source target. Some styles are broken when trying to display
> the it in the browser (i.e. a tooltip is missing the borders, the window has
> no background).
>
> If I run a 'build' these errors are gone and the rendering looks fine.
>
> In [1] you can find a source.png and the build.png to see how the rendering
> looks in chrome. The (playing around state) source is in cute.tgz.
>
> Any ideas what's wrong here?
>
> Thanks,
> Cajus
>
> [1]
> https://ferdi.naasa.net/oc/public.php?service=files&token=9bae9a7535dbd169f5e6c10f23d19edc37d6dad9&file=/qx
> <signature.asc>------------------------------------------------------------------------------
> Live Security Virtual Conference
> Exclusive live event will cover all the ways today's security and
> threat landscape has changed and how IT managers can respond. Discussions
> will include endpoint security, mobile security and the latest in malware
> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/_______________________________________________
> qooxdoo-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel


------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
Reply | Threaded
Open this post in threaded view
|

Re: Build / Source differences

Cajus Pollmeier
Hi Martin,

the link can't be broken, it's hosted by 1und1 ;-)

Looks like it works for me, but I've just moved it to
http://ferdi.naasa.net/qx/

Am Dienstag, 3. Juli 2012, 14:05:19 schrieb Martin Wittemann:
> Hey,
> seems like the link is broken. :(
> But still, your issue sounds strange. Usually, the build version breaks
> applications and does not heal them. ;) But I can't tell you much, only
> that we have never heard of such an Issue and we should check out whats
> the reason. Do you have a custom theme based on a qooxdoo theme? Maybe
> some keys in our theme changed and you use them in your application?

I'm using the indigo theme, no custom stuff. What I'm trying to experiment
with is "dynamically building a widget based on a qt designer ui description".
From qx 1.x times, I remember that builds break from time to time - yes ;-)
This time it's the opposite way.

"generate clean" should remove everything which might cause problems, right?
Hmm. I'm including one external js file that just contains one method to parse
the xml data. Maybe it's because of that one? Or did I mix up something in the
config.json file when including additional information?

Cheers,
Cajus

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel

signature.asc (197 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Build / Source differences

MartinWittemann
Administrator
Hey,
the link can't be broken, it's hosted by 1und1 ;-)
Haha. :) But the site keeps telling me: "Cloud nicht verfügbar"

Looks like it works for me, but I've just moved it to
http://ferdi.naasa.net/qx/
Much better. :)

I'm using the indigo theme, no custom stuff. What I'm trying to experiment 
with is "dynamically building a widget based on a qt designer ui description".
From qx 1.x times, I remember that builds break from time to time - yes ;-)
This time it's the opposite way.
I guess the problem source could be the first error message. Seems like a Mixin is missing and I don't know whats happening if thats missing.

"generate clean" should remove everything which might cause problems, right?
A distclean would be the absolute save way because it clears everything! :)

Hmm. I'm including one external js file that just contains one method to parse
the xml data. Maybe it's because of that one? Or did I mix up something in the
config.json file when including additional information?
I don't think so. Try to clean distclean and build again. That could fix the issue.

Regards,
Martin

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
Reply | Threaded
Open this post in threaded view
|

Re: Build / Source differences

Cajus Pollmeier
Ok. distclean does not change anything. Its still broken.

Error messages: if you're talking about the ones prefixed with "***", they're
from my application and just tell me that there are uninterpreted elements in
the input XML data.

See

http://ferdi.naasa.net/qx/cute/build

vs

http://ferdi.naasa.net/qx/cute/source

Cheers,
Cajus

Am Dienstag, 3. Juli 2012, 14:59:41 schrieb Martin Wittemann:

> Hey,
> the link can't be broken, it's hosted by 1und1 ;-)
> Haha. :) But the site keeps telling me: "Cloud nicht verfügbar"
>
> Looks like it works for me, but I've just moved it to
> http://ferdi.naasa.net/qx/
> Much better. :)
>
> I'm using the indigo theme, no custom stuff. What I'm trying to experiment
> with is "dynamically building a widget based on a qt designer ui
> description".
>
> >From qx 1.x times, I remember that builds break from time to time - yes
> >;-)
>
> This time it's the opposite way.
> I guess the problem source could be the first error message. Seems like a
> Mixin is missing and I don't know whats happening if thats missing.
>
> "generate clean" should remove everything which might cause problems,
> right? A distclean would be the absolute save way because it clears
> everything! :)
>
> Hmm. I'm including one external js file that just contains one method to
> parse the xml data. Maybe it's because of that one? Or did I mix up
> something in the config.json file when including additional information?
> I don't think so. Try to clean distclean and build again. That could fix
> the issue.
>
> Regards,
> Martin

--
Cajus Pollmeier <[hidden email]> (Head of Development)
* GONICUS GmbH * Moehnestrasse 11-17 * D-59755 Arnsberg
* Tel.: +49 (0) 29 32 / 9 16 - 0 * Fax: +49 (0) 29 32 / 9 16 - 223
* http://www.GONICUS.de

* Sitz der Gesellschaft: Moehnestrasse 11-17 * D-59755 Arnsberg
* Geschaeftsfuehrer: Rainer Luelsdorf, Alfred Schroeder
* Vorsitzender des Beirats: Juergen Michels
* Amtsgericht Arnsberg * HRB 1968

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel

signature.asc (197 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Build / Source differences

MartinWittemann
Administrator
> Ok. distclean does not change anything. Its still broken.
>
> Error messages: if you're talking about the ones prefixed with "***", they're
> from my application and just tell me that there are uninterpreted elements in
> the input XML data.
No, I was talking about the first line in the console in your picture which shows a failed GET request.

>
> See
>
> http://ferdi.naasa.net/qx/cute/build
>
> vs
>
> http://ferdi.naasa.net/qx/cute/source


Thanks for the links. It seems to be browser or something else dependent because both version work the same. Let me guess, you are working on Linux and Firefox 13?

Regards,
Martin
------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
Reply | Threaded
Open this post in threaded view
|

Re: Build / Source differences

Cajus Pollmeier
Am Dienstag, 3. Juli 2012, 16:56:59 schrieb Martin Wittemann:

> > Ok. distclean does not change anything. Its still broken.
> >
> > Error messages: if you're talking about the ones prefixed with "***",
> > they're from my application and just tell me that there are
> > uninterpreted elements in the input XML data.
>
> No, I was talking about the first line in the console in your picture which
> shows a failed GET request.
>
> > See
> >
> > http://ferdi.naasa.net/qx/cute/build
> >
> > vs
> >
> > http://ferdi.naasa.net/qx/cute/source
>
> Thanks for the links. It seems to be browser or something else dependent
> because both version work the same. Let me guess, you are working on Linux
> and Firefox 13?
Ah. I'm using Linux and Chrome mostly. Just tried

  Chrome 20.0.1132.43
  Firefox 13.0.1

both show broken source, while

  Opera 12.0

renders OK.

The interresting thing is that (according to the webserver log) the
MBoxShadow.js is never requested from the server. Even if I clear the caches.

Regards,
Cajus

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel

signature.asc (197 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Build / Source differences

MartinWittemann
Administrator
Hi,
Hm, I think thats the thing you should take a deeper look at. Check the network pannel and try to find out why the file is missing. Might be a server issue or might be a wrong URL.
Regards,
Martin


Am 03.07.2012 um 17:24 schrieb Cajus Pollmeier:

> Am Dienstag, 3. Juli 2012, 16:56:59 schrieb Martin Wittemann:
>>> Ok. distclean does not change anything. Its still broken.
>>>
>>> Error messages: if you're talking about the ones prefixed with "***",
>>> they're from my application and just tell me that there are
>>> uninterpreted elements in the input XML data.
>>
>> No, I was talking about the first line in the console in your picture which
>> shows a failed GET request.
>>
>>> See
>>>
>>> http://ferdi.naasa.net/qx/cute/build
>>>
>>> vs
>>>
>>> http://ferdi.naasa.net/qx/cute/source
>>
>> Thanks for the links. It seems to be browser or something else dependent
>> because both version work the same. Let me guess, you are working on Linux
>> and Firefox 13?
>
> Ah. I'm using Linux and Chrome mostly. Just tried
>
>  Chrome 20.0.1132.43
>  Firefox 13.0.1
>
> both show broken source, while
>
>  Opera 12.0
>
> renders OK.
>
> The interresting thing is that (according to the webserver log) the
> MBoxShadow.js is never requested from the server. Even if I clear the caches.
>
> Regards,
> Cajus
> <signature.asc>------------------------------------------------------------------------------
> Live Security Virtual Conference
> Exclusive live event will cover all the ways today's security and
> threat landscape has changed and how IT managers can respond. Discussions
> will include endpoint security, mobile security and the latest in malware
> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/_______________________________________________
> qooxdoo-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel


------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
Reply | Threaded
Open this post in threaded view
|

Re: Build / Source differences

Cajus Pollmeier
Am Mittwoch, 4. Juli 2012, 08:10:33 schrieb Martin Wittemann:
> Hi,
> Hm, I think thats the thing you should take a deeper look at. Check the
> network pannel and try to find out why the file is missing. Might be a
> server issue or might be a wrong URL. Regards,
> Martin

Ok. I think we can ignore this one. It happens on my system only and I cannot
reproduce it on other systems running the same (browser-)software. For me it
looks a bit like there's a certain system library kinda broken that affects
firefox and chrome on my system.

It's definitely no http server issue and no issue with a wrong URL. Both
browsers are able to load the file from the server if I paste the URL to the
address field.

FTR, the network panel shows up with:

GET
http://ws-1.muc/qooxdoo/framework/source/class/qx/ui/decoration/MBoxShadow.js 
cute.js:72
loadScript cute.js:72
loadScriptList cute.js:99
qx.$$loader.initUris cute.js:191
qx.$$loader.init cute.js:176
elem.onreadystatechange.elem.onload

The request never gets to the server and it is marked as "pending" on the
network panel.

Whatever leads to this - just ignore it ;-)

Thanks for your help,
Cajus

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel

signature.asc (197 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Build / Source differences [solved]

Cajus Pollmeier
Just in case others run into these issues:

I had the ghostery plugin enabled in Chrome and Firefox. Whitelisting the URL
for the development URLs did the trick. After knowing what it was, one can
find [1] to notice that I'm not the only one ;-)

Sigh.

Cheers,
Cajus

[1] http://qooxdoo.678.n2.nabble.com/Qooxdoo-1-4-and-FF4-issue-td6255260.html

Am Mittwoch, 4. Juli 2012, 09:48:47 schrieb Cajus Pollmeier:

> Am Mittwoch, 4. Juli 2012, 08:10:33 schrieb Martin Wittemann:
> > Hi,
> > Hm, I think thats the thing you should take a deeper look at. Check the
> > network pannel and try to find out why the file is missing. Might be a
> > server issue or might be a wrong URL. Regards,
> > Martin
>
> Ok. I think we can ignore this one. It happens on my system only and I
> cannot reproduce it on other systems running the same (browser-)software.
> For me it looks a bit like there's a certain system library kinda broken
> that affects firefox and chrome on my system.
>
> It's definitely no http server issue and no issue with a wrong URL. Both
> browsers are able to load the file from the server if I paste the URL to
> the address field.
>
> FTR, the network panel shows up with:
>
> GET
> http://ws-1.muc/qooxdoo/framework/source/class/qx/ui/decoration/MBoxShadow.
> js cute.js:72
> loadScript cute.js:72
> loadScriptList cute.js:99
> qx.$$loader.initUris cute.js:191
> qx.$$loader.init cute.js:176
> elem.onreadystatechange.elem.onload
>
> The request never gets to the server and it is marked as "pending" on the
> network panel.
>
> Whatever leads to this - just ignore it ;-)
>
> Thanks for your help,
> Cajus

--
Cajus Pollmeier <[hidden email]> (Head of Development)
* GONICUS GmbH * Moehnestrasse 11-17 * D-59755 Arnsberg
* Tel.: +49 (0) 29 32 / 9 16 - 0 * Fax: +49 (0) 29 32 / 9 16 - 223
* http://www.GONICUS.de

* Sitz der Gesellschaft: Moehnestrasse 11-17 * D-59755 Arnsberg
* Geschaeftsfuehrer: Rainer Luelsdorf, Alfred Schroeder
* Vorsitzender des Beirats: Juergen Michels
* Amtsgericht Arnsberg * HRB 1968

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel

signature.asc (197 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Build / Source differences [solved]

Thomas Herchenroeder
The sad thing is that the issue is so hard to detect ...

T.

On 07/09/2012 10:05 AM, Cajus Pollmeier wrote:
Just in case others run into these issues:

I had the ghostery plugin enabled in Chrome and Firefox. Whitelisting the URL 
for the development URLs did the trick. After knowing what it was, one can 
find [1] to notice that I'm not the only one ;-)

Sigh.

Cheers,
Cajus

[1] http://qooxdoo.678.n2.nabble.com/Qooxdoo-1-4-and-FF4-issue-td6255260.html

Am Mittwoch, 4. Juli 2012, 09:48:47 schrieb Cajus Pollmeier:
Am Mittwoch, 4. Juli 2012, 08:10:33 schrieb Martin Wittemann:
Hi,
Hm, I think thats the thing you should take a deeper look at. Check the
network pannel and try to find out why the file is missing. Might be a
server issue or might be a wrong URL. Regards,
Martin
Ok. I think we can ignore this one. It happens on my system only and I
cannot reproduce it on other systems running the same (browser-)software.
For me it looks a bit like there's a certain system library kinda broken
that affects firefox and chrome on my system.

It's definitely no http server issue and no issue with a wrong URL. Both
browsers are able to load the file from the server if I paste the URL to
the address field.

FTR, the network panel shows up with:

GET
http://ws-1.muc/qooxdoo/framework/source/class/qx/ui/decoration/MBoxShadow.
js cute.js:72
loadScript cute.js:72
loadScriptList cute.js:99
qx.$$loader.initUris cute.js:191
qx.$$loader.init cute.js:176
elem.onreadystatechange.elem.onload

The request never gets to the server and it is marked as "pending" on the
network panel.

Whatever leads to this - just ignore it ;-)

Thanks for your help,
Cajus



------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and 
threat landscape has changed and how IT managers can respond. Discussions 
will include endpoint security, mobile security and the latest in malware 
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/


_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
Reply | Threaded
Open this post in threaded view
|

Re: Build / Source differences [solved]

Alex Shneyder
In reply to this post by Cajus Pollmeier
Cajus Pollmeier wrote
Just in case others run into these issues:

I had the ghostery plugin enabled in Chrome and Firefox. Whitelisting the URL
for the development URLs did the trick. After knowing what it was, one can
find [1] to notice that I'm not the only one ;-)

Sigh.

Cheers,
Cajus
Oh thank you very much, Cajus. I had  exactly same issue with Iceweasel under Debian %). Whitelisting the host in Ghostery config dialog solve the issue. Thank you :)

regards,
Alex
Reply | Threaded
Open this post in threaded view
|

Re: Build / Source differences [solved]

Cajus Pollmeier
Hehe. I've filed a "false positive" bug at the ghostery site:

https://getsatisfaction.com/ghostery/topics/false_positive_when_using_the_qooxdoo_framework

Let's see what they do with it.

Am Freitag, 13. Juli 2012, 08:39:41 schrieb Alex Shneyder:

> Cajus Pollmeier wrote
>
> > Just in case others run into these issues:
> >
> > I had the ghostery plugin enabled in Chrome and Firefox. Whitelisting the
> > URL
> > for the development URLs did the trick. After knowing what it was, one
> > can find [1] to notice that I'm not the only one ;-)
> >
> > Sigh.
> >
> > Cheers,
> > Cajus
>
> Oh thank you very much, Cajus. I had  exactly same issue with Iceweasel
> under Debian %). Whitelisting the host in Ghostery config dialog solve the
> issue. Thank you :)
>
> regards,
> Alex
>
> --
> View this message in context:
> http://qooxdoo.678.n2.nabble.com/Build-Source-differences-tp7580511p758063
> 0.html Sent from the qooxdoo mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------------
> --- Live Security Virtual Conference
> Exclusive live event will cover all the ways today's security and
> threat landscape has changed and how IT managers can respond. Discussions
> will include endpoint security, mobile security and the latest in malware
> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
> _______________________________________________
> qooxdoo-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
qooxdoo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel

signature.asc (197 bytes) Download Attachment